参考资料: http://blog.csdn.net/asialyf/article/details/78784196

共分2种方式:

#1. 推荐第一种比较方便

首先打开根目录下的 build.gradle 文件。并在文档最后换行输入以下代码:

ext{
    //SDK
    minSdkVersion = 15  
    targetSdkVersion = 26
    compileSdkVersion = 26

    //dependencies
    supportLibraryVersion ='27.1.0'
    butterknifeVersion = '8.8.1'
}

如下图 :

接着打开 app mudule下的 build.gradle 文件, 使用刚刚配置的 ext

#2. 第二种方式

1.在项目根目录下创建.gradle文件,如:config.gradle

2.在根目录下的build.gradle文件中引入创建的配置文件

apply from:"config.gradle" 

3.最后config.gradle中文件内容可以自己定义

ext {  
    // 用于编译的SDK版本  
    COMPILE_SDK_VERSION = 23  

    // 用于Gradle编译项目的工具版本  
    BUILD_TOOLS_VERSION = "24.0.2"  

    // 最低支持Android版本  
    MIN_SDK_VERSION = 14  

    // 目标版本  
    TARGET_SDK_VERSION = 23  

    APPCOMPAT_VERSION = '23.2.1'  

} 

4.在app目录下的build.gradle中使用

dependencies {  
    compile fileTree(include: ['*.jar'], dir: 'libs')  
    compile "com.android.support:cardview-v7:${APPCOMPAT_VERSION}"  
    compile "com.android.support:appcompat-v7:${APPCOMPAT_VERSION}"  
    compile "com.android.support:design:${APPCOMPAT_VERSION}"  
    compile 'com.github.bumptech.glide:glide:3.7.0'  
}