用 ext 统一管理版本时碰见这个奇葩的BUG, 于是谷歌了下, 目前是解决了这个问题, 但是原因不是很清楚.

参考: https://stackoverflow.com/a/47268500/8920453

我是在使用 “com.android.support:design” 这个包出现的问题, 报的编译版本跟 runtime 版本不一致. 起初以为是其他 module 里使用了别的版本导致冲突, 结果查了几分钟没找到其他模块有用到这个包. 全局搜索也没发现. 就只能怀疑是当前 module 里使用的这个版本的问题. 但是明明使用的就是跟报错时显示的版本是一样的啊.为啥还会显示版本不一致呢? 这个我现在也没想通.

解决方式就是把 implementation 这个依赖的方式改为 api 然后重新 rebuild 就好了

一脸懵逼